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1 Revision History 

Revision Date Comments 

A 7/21/2020 Initial release 
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2 Warnings / Disclaimers 

The information contained herein is provided "as is" and uAvionix assumes 

no liability for its use. No warranty, either express or implied, is given, 

including but not limited to, with respect to the accuracy, correctness, 

reliability and fitness for a particular purpose of the information. uAvionix is 

not liable for damages arising from the use or misuse of this product. 
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4 Introduction 

GNSS Toolkit is a Windows application for the evaluation, configuration, and control of a 

GNSS receiver over a serial connection. GNSS Toolkit provides a configuration 

interface for the uAvionix truFYX GNSS receiver and utilizes the truFYX NMEA data 

interface implementation, which is an adaptation of and extension to the NMEA 0183 

Interface Standard.  

  



UAV-1005664-001                    Page 7 | 27 

Rev A 

5 Installation 

5.1 Downloading GNSSToolkit.exe 

GNSS Toolkit can be downloaded free-of-charge from our website 

(https://uavionix.com/support/). 

5.2 Connecting to a GNSS Receiver 

GNSS Toolkit is compatible with GNSS Receivers communicating over a serial interface 
at a baud rate between 300 and 115200.  

 

While a receiver is plugged in to the computer, press the toolbar button with the blue 
and grey cogs: 

 
 

Alternatively, this functionality can be accessed from the menu bar “Tools > Connect to 
GPS…”: 

 
 

Enter the desired Communication Port and Baud Rate into the window that pops up and 
click “OK”: 

https://uavionix.com/support/
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Check the “NMEA Monitor” tab for messages in the “Receive” pane:  

 

 
 
If the “Receive” pane is being filled with messages, the GNSS receiver was successfully 
connected. Data will begin populating the other tabs.  
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If the “Receive” pane is empty, or if you receive an error indicating GNSS Toolkit was 
unable to connect to the specified communication port, check that the receiver is fully 
powered on and is transmitting NMEA messages. Also check your computer’s Device 
Manager to ensure the device is connected to the computer and appears on a COM 
port.  

 

 
 
Once a GNSS receiver has been connected to GNSS Toolkit successfully, the COM 
port and baud rate will be automatically saved for the next use.  
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6 Configuration 

6.1 GNSS Toolkit  

GNSS Toolkit offers multiple customization options.  

6.1.1 Known User Position 
Data of interest such as horizontal error can be calculated once a known user position 

has been saved in GNSS Toolkit. 

From the menu bar, open “Tools > Settings > Set User Position…”: 

 

In the window that pops up, enter the coordinates of the receiver’s current known 

position in signed decimal notation, with altitude in meters, and then click OK:  

 

6.1.2 DOP Threshold 
A custom Dilution of Precision threshold can be set that is used when accepting data 

points.  

From the menu bar, open “Tools > Settings > Set DOP Threshold…“: 
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In the window that pops up, enter the desired DOP threshold and click OK: 

 

6.1.3 Appearance and Toolbar Customization 
The appearance of the application as well as the buttons which appear in its toolbars 

and menus can be edited for easy access to frequently-used controls.  

To access these customization options, navigate to the View menu in the menu bar: 

 

Within “Application Look,” the theme of the application can be changed to a dark theme 

or a blue theme:  
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The “Status Bar” option toggles whether the status bar at the bottom of the window is 

shown. The status bar displays useful information such as GPS Quality and 

Transmit/Receive status: 

 

 

Unchecking the “Status Bar” option hides this information until the button is rechecked.  

Controls such as those found in the menu bar can be added to the tool bar through 

“View > Toolbars and Docking Windows > Customize…”: 

 

This option can also be accessed by right clicking the tool bar:  

 

A window will appear with several more customization menus:  
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While this window is open, right clicking on any button in the main GNSS Toolkit window 

will offer options to edit the appearance of the button. Additionally, buttons found in the 

“Commands” pane of the “Commands” tab of the customization window can be dragged 

into the menu bar or onto the tool bar: 
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To reset the toolbars to their original appearance, use the “Reset All” button in the 

Toolbars tab of the customization window, or click the downward arrow on the toolbar 

and then navigate to “Add or Remove Buttons > Standard > Reset Toolbar…”: 

 

 

Additional functionality in these menus should only be used by advanced users.  
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6.2 Receiver Configuration 

A connected receiver can be configured through NMEA messages sent from GNSS 

Toolkit via the NMEA Monitor tab. Specific configuration messages for the truFYX can 

be found in the Receiver Configuration tab.  

6.2.1 General Configuration 
To send NMEA messages to the connected receiver, navigate to the NMEA Monitor tab: 

 

Enter a valid NMEA sentence in the text box at the top of this pane and click the “Send” 

button to transmit it to the receiver. All messages sent by GNSS Toolkit are displayed in 

the “Transmit” pane:  

 

The “Automatic Checksum” checkbox toggles whether GNSS Toolkit calculates and 

appends a valid NMEA checksum to the transmitted message: 

 

Review your device’s Integration Control Document to find which NMEA commands it 

accepts and their syntaxes.  Full information on the NMEA interface definition for 

truFYX, refer to the uAvionix truFYX NMEA ICD (UAV-1002084-001). 

6.2.2 truFYX Configuration 
Some truFYX-specific configuration messages can be built and sent through the 

Receiver Configuration tab:  
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Each command corresponds to a row on this screen, and each column in the row 

corresponds to a field of the message. By selecting the “<keep>” option in a selection 

box, the existing configuration for the corresponding setting will be maintained: 

  

Selecting items in a selection box or entering valid values in a text box and then clicking 

the corresponding “Send” button will send the message with those settings: 

  

The resulting message can be viewed on the NMEA Monitor tab: 

  

The PUAVNOM selection box under “NOM” supports selecting multiple items: 
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For the PUAVNOM message, the selected messages in the NOM box will be enabled 

and all unselected messages will be disabled.   
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7 GNSS Evaluation 

Once a GNSS receiver has been connected and NMEA messages are being shown in 

the NMEA Monitor tab, a GNSS fix will become available for evaluation on the Front 

Panel Status, Scatter Plot, and Position Plot tabs.  

7.1 Front Panel Status 

The Front Panel Status tab displays basic, real-time information about the GNSS fix and 

the satellites providing the solution.  

The top pane several colored bars, each corresponding to a visible satellite. When no 

satellites are visible to the receiver, twelve empty bars are shown: 

 

When satellites are visible to the receiver, the number of bars changes to match the 

number of visible satellites. Each bar shows the corresponding satellite’s ID as a 

number below the bar, its signal-to-noise ratio (SNR) as the height of the colored portion 

of the bar, and its type as shown by the color of the bar: 

 

The bottom left pane shows information about the GNSS solution:  



UAV-1005664-001                    Page 20 | 27 

Rev A 

 

The bottom right pane shows satellite position, trails, and the azimuth/elevation mask: 

 

Right clicking anywhere in this tab brings up a context menu to clear satellite trails or 

the azimuth/elevation mask: 
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7.2 Scatter Plot 

The Scatter Plot tab shows the GNSS solution on a scatter plot, with new position 

samples being drawn as they are reported by the receiver: 

 

The latest position sample is circled in yellow, while the average of all samples is 

indicated by a green circle. On the top left, the horizontal error from the latest sample 

relative to the known user position (See Section 6.1.1) is displayed, as is the number of 

samples so far. On the top right, + (plus) and - (minus) sign buttons control the zoom 

level of the plot, with - zooming out and + zooming in. The zoom level can also be 

adjusted by scrolling the mouse wheel.  

The center or origin of the plot can be set to one of three positions: the next position 

sample, the average position, and the known user position. To change this setting, right-

click anywhere on the scatter plot to open a contextual menu:  
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Select the desired center from the contextual menu that appears. Note that the “Center 

Next Position Sample” will change the center of the plot only once; it will not follow 

position samples as they are reported. Conversely, the “Center On Average” option will 

follow the green circle as it is updated.  

The “Clear Plot” button in this contextual menu will remove all samples from the scatter 

plot, clear the average, and reset the sample count on the top left.  

7.3 Position Plot 

The Position Plot shows detailed real-time GNSS information, positional line graphs, 

and horizontal accuracy and precision measures.  
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The left panel shows positional information for the current sample, the least-squares 

fitting, and the average. It also displays the number of samples, horizontal precision limit 

(HPL), horizontal figure-of-merit (HFOM), horizontal error (HErr), and the number of 

HPL Violations detected so far:  
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The right side of the tab displays four line graphs. They plot latitude, longitude, altitude, 

and horizontal precision and accuracy measures:  

 

The legend to the right of each graph identifies the dataset to which each line belongs. 

Some datasets do not appear until they have samples to show, such as HPL Violations.  

Right-clicking anywhere on the Position Plot tab will show a context menu with the 

option to clear all graphs and statistics on the tab: 

 

7.4 Recording/Playback 

NMEA messages can be saved to a text file and opened for playback at a later time.  

From the menu bar, navigate to “Tools > Record/Play”: 
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These options can also be accessed through the toolbar:  

 

The Record Data button will open a file explorer window through which a file can be 

selected or created as the destination for NMEA messages obtained in the current 

session to be saved: 

 

The “Play Back Data” button will open a similar window through which a text (*.txt) file 

containing NMEA messages can be selected:  
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Clicking the Open button will send the NMEA messages contained in the file to GNSS 

Toolkit, as if they were being sent by a GNSS receiver. The front panel, plots, and 

NMEA monitor will display content from theses recorded messages, again just as if a 

GNSS receiver were sending the NMEA messages.  

During playback or recording, the Stop button will become usable. Clicking it will close 

the currently opened NMEA file, saving the recorded NMEA messages or allowing a 

different NMEA source to be used by GNSS Toolkit,  

8 Product Information 

Information about GNSS Toolkit, including the version number, part number, and 

copyright, can be found by navigating to Help > About: 

 

The ? (question mark) button on the toolbar will also show the product information: 

 

The product information is displayed in a pop-up window: 
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Click OK to close the pop-up window and resume use of GNSS Toolkit.  

 


